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1 Import Satellite Ground Image and Data in PVsyst

In this chapter, we will explore an efficient method to import both ground topography and
ground images in just a few easy steps using the V8 feature, "Download a satellite
ground image and/or ground data". This approach offers a significantimprovement over
the previous method (described in the next chapter), as it eliminates the need for
manually selecting map points and converting data to CSV format.

e Access the Download Tool

o Inthe 3D Scene of PVsyst, go to File > Import > Download a satellite
ground image and/or ground data.

 Shading scene construction

File Create Select Edit Transform View Tools Help

#| New scene Ctrl+N Yy 2 z 1 LR > e
Read cuowg}’x"TKJL'Y Q% 9D @M |/ A /S & = _
ead scene rl+
- Point of view Zoom Render Modules Measure Modify Tools Reference
Read building :
; Scene objects | Tools
Read objects i-Zenith E= t_."'
: - % Scene objects
»  Import > @ Importa 3D scene (305, DAE, PVC) Name L
4 Export scene (:SHD) Ctrl+S | wr| Import a Helios3D file (H2P) & PV Fields (0)
Export selected objects (.SHO) i Impert ground data (CSV, TIF) i) Objects (0)
B Savescene view >| [@ Imperta ground image :
e Print Cirlep & Download a satellite ground image and/or ground data
® Cancel Ctrl+Q
Close scene Ctrl+W
¥ Orientations
HUnEnmhunsmanagemant = @
=32 oOrientations (1)
“ #1: Fixed, Tilt 20.0°, Azim, 0.0%
» Groups and zones
| R cancel ‘ Close scene
West South
Grid cell sze: 1.00 m Geographical - Perspective view & X:-3.56, ¥:-19.18 m Active area : 0.00 m* Total number of modules: 0

Figure 1: Download satellite image and ground data

e Explore the Interactive Map

An interactive map will appear, centered on your project location. You can zoom
in, zoom out, and drag the map to adjust the view. Note that the map is limited to
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an approximately 11 km x 11 km area to maintain consistency between the
project’s location and the imported terrain data.

e Select Topography Data

For this tutorial, we will import both the ground image and its topographic data. To
do this, tick the box labeled "Also import topography data" at the bottom of the
map window.

® Interactive Map — (] X

l__—l Satellite v

—

Figure 2: Selected area on Bing Interactive map
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Once you have selected the desired area, click OK. PVsyst will then download
the image and topographic data for the displayed region.

File Create Select Edit Transform View Tools Help
- o] . > —
Se M- sl at |eele (90 (@m | a(vec|/ o (lE| -0
History Selection Point of view Zoom Render Modules Mezsure Modify Tools Reference
Zenith Bt | Scene objects | Tools
¥ Scene objects
 Name ¢
&5 PV Fields (0)
() Objects (2)
s8] Ground Image
B3 Ground object

| Grid cel sze: 50.00 m

... South

Geographical - Perspective view b X: -258.33, Y: 509.73 m Active area : 0.00 m*

¥ Orientations

[} Orientations (1)
- #1: Fixed, Tit 20.0°, Azim. 0.0°

 Groups and zones

x| =]

Total number of modules: 0

Figure 3: Imported ground image and object in 3D Scene

Crop the Ground Image (Optional)

If the imported image is too large, you can crop it to focus on the desired area:

o Double-click Ground Image in the Scene objects panel on the right side
of the Shading Scene Construction window. This will open the Ground

Image Edition Tool.

Transform  View Tools Help

*qWW%.ﬁﬁﬁ

Point of view

a
Me:

& Qid@

Zoom

9O |E@E
Rend

er Modules

) "-
S

|/ o |Hlz | .9
Modify Tools Reference
Scene objects | Tools

¥ Ground Image

Ground Image

X1 - Origin———————————————————|
X {West 0.000  m

¥/ South 0000 m

X2-2nd pointon axis |

X/ West -100.00 m
¥/ South 0000 m
Distance X1 ->X2 4552 m
Image base width 10000 m
. Edt
oot :
@ | Fow
% 5un position
oo || g |

Total number of modules: 0

| Zenith East
|
|
"\Nc_r_.t.h
"";\‘i’esl
South
Grid cell size: 50.00 m Geographical - Perspective view & X:-162.45, Y:524.48 m Active area : 0.00 m?
Figure 4: Ground Image edition tool
o Atthe bottom of the panel, click on ‘Crop’ icon.
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her settings
Distance ¥1-> %2 435.92 m
Image base width 100.00 m
| o Edit
]
Opadty < | @ showpide |

o[

Figure 5: Crop button in edition tool

o Inthe Ground Image Cropping window, drag the sides of the cropping
box and center it on the desired section.

® Ground Image Cropping

[ x Cancel H JCrop

Figure 6: Ground Image Cropping tool

o Once the desired area is selected, click Crop.

o The ground image may be hidden by the ground object. To see the ground
image after resizing, delete the ground object (you can restore it with ctrl-z
afterward)
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2 Importing a ground topography from Google Earth

e Open Google Earth Pro (this software is free even if it’s called “Pro”)

e From the menu “Tools>Options>Navigation”, check “Do not automatically tilt
while zooming” (in order to be always in a 90° top view from the ground)

e Select alocation by setting and address or by scrolling with the mouse

=

e Click onthe “Path” tool and draw as many points as possible with the
mouse to define the desired area (the polygon tool will only generate the
elevation data for the polygon’s corners, it’s not sufficient to extract the
topography of the polygon area)

e On “Altitude tab”, select “Ground level”

‘§ Google Earth Pro

¥ Recherche

| Annecyle-Vieu pas i =
—————— Google Earth - Nouveau Trajet

Nom : | SRR

QAn

Description | Style, Couleur | Affichage | Altitude | Mesures

| Ajouter un lien... | | Ajouter une image Web... | |Ajouter une image locale... |

|+ el

¥ Lieux
B IVies
& Vi

]

La

=t

Le Christ Rédempteur
Le Grand Canyon

Sydney

(|| [+]+]

Figure 7 : Google Earth Pro

e Clickon “OK” to close the path tool
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e Selectthe generated path and save it as a KML file :

o Sans titre - Trajet
- ¥ %% Sans titre - Tajet
o Sans titre - Trajet
S Sans titre - Trajet

0¥ o Sans titre - Taict

e e = =
4

(Q[m]| BEIRAIFS
e —— Couper —
¥ Calgues Copier e
v @ @ Base de dd Supbrimer Fan

B Annonc PP

' P Fron®er: TOTTOT Tt

Enregistrer le lieu sous...

L = Photls

P Routes ETOOy e par e

b3 Bitimen Utiliser la vue actuelle

d iﬁ Météo | Afficher le profil de dénivelé

b 9% Galerie "

» [ Plus Proprigtés

“ [#] Relief

Figure 8 : google earth - Save as

e Go to https://www.gpsvisualizer.com/convert_input

e Select “Plain text” as “Output format”
e Selectyour KML file from “Upload your files here”
e Select “Semi-colon” for “Plain text delimiter”

e Select “Best available source” in “Add DEM elevation data” list

Output format: § @ plain textl Oeprx O Google Earth KML

Upload your files here:  Eja 21 location.krml

10 M E F
(10 MB max. total size, File #2 | Sélect. fichiers | Aucun fichier cheisi

.Zip/.0z is supported)
File #3 Aucun fichier choisi
Show more file boxes

Or paste your data here: |nzme,desc,latitude, longitude

Force text data to be this type: | default A

Or provide the URL of a file on the Web: |

Plain text delimiter: Plain text output units:

Add estimated fields: [Jspeed [ heading [ slope (%) [distance [JvMG [pace
Add DEM elevation dataI | best available source Vﬁ

Save these settings # Load from saved

Figure 9 : Google earth - Output format
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https://www.gpsvisualizer.com/convert_input

e Click on “Show advanced parameters”
e Select “No” for “Repeat header row in plain-text output”

o Select “Yes” for “Output UTM coordinates”

_— -

Repeat header row in plain-text output
Qutput UTM coordinates: || ves v [Jin plain-text output only)
Time offset: E hours
Moving average range for estimated fields (speed, slope, etc.): point({s)

Check this box if your GPX input file uses the wrong unit (km/h) for speed data: ]

Figure 10 : Misc. Options

e C(Click on “Convert”

e Copy the generated content

The contents of your file are also displayed in this box, if you'd rather cut and paste:

ype; latitude;longitude;utm zone;utm easting;utm northing;altitude (m);name;desc
364489382; 3. 870649091 ; 31T;569374.8;4912725.7;1437.1;5ans titre - Trajet;
364472991;3.870588669; 31T;569370;4912723.9;1438.4; ;
364468877;3.878533200;31T;569365.6;4912723.
364468992;3.878499121;31T;569362.9;4912722.5;
364453448;3.878461007 ;31T ;569359.9;4912721.6;
364453612;3.870456815;31T;569359.6;491272]1.6;
364445267;3.870435609; 31T ;569357.9;4912728.7;
364425931;3.870372310;31T;569352.9;4912718.5;
364414733;3.870338587;31T;569350.2;4912717.2;
364489141;3.870321745;31T;569348.8;4912716.6;
364486322;3.870313318;31T;569348.2;4912716.2;

CTRC T

-

e e

-

EERRRRRfsse

.95

-

LA SCAAAAEAA - OTASAASTST . ST . CEnTS AT N . AnaNTAr S .aaan

Map this data: Leaflet, Google Maps, Google Earth, JPEG

. W
map, SV5 map, or elevation profile — or go to the map |

Figure 11 : Google Earth - Data format

e Pastthe content to Excel
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e Clickon menu “Data>Convert” and select “Delimited” file

Fichier Accueil Insertion Mise en page Formules Révision Affichage Automate Aide
[y A partir d'un fichier texte/CSV [ A partir de Iimage ~ |TL [ Requétes et connexions - al ? S = Remp
5 Zd x|z —
[® A partir du web [® Sources récentes [} @ ,[—% w X ) Suppr
Obtenirdes - Donnéesb.. Devises (Fr.. Donnéesg.. | | Z| Ter | Filtrer Convertir
données ~ E21 A partir de Tableau ou d'une Plage [ Connexions existantes B 5 B DEVES U *0- 7] | & N Valida
Récupérer et transformer des données Requétes et connexions Types de données Trier et filtrer
Al - I type;latitude;longitude;utm_zone;utm_eq Assistant Conversion - Etape 1 sur 3 7 x
A B C D E F G L Assistant Texte a déterminé que vos données sont de type Délimité, o P
1 [type:latitude; pngitude; utm_zone;utm_easting,utm_northing:altitude (m);name:desc 5i ¢e choix vous convient, choisissez Suivant, sinon choisissez I type de données qui dérit le
2 |T:44.364489:82.3.870649091,31T,569374.8,4912726.7,1437.1;Sans titre - Trajet; migux vos données,
3 |T:44.3644725/91,3.870588669,31T,569370,4912723.9,1438.4;; Type de données d'origine
4 |T;44.364468¢77,3.870533200;31T,569365.6,4912723.4,1439.5;; de fichier qui décrit le mieux vos données :
5 |T:24 3644804023 870499121:317:560362.9-4012722 5:1240.1:- ;r?;;u::rcancat’énr;s tels que des virgules ou des tabulations séparent
6 [T44.364453448.3.870461007,31T,569359.0,4912721.6,1440.7.; (O Largeur fixe - Les champs sont alignés en colannes et séparés par des espaces
7 |T:44.364453€12;3 870456815;31T;569359.6,4912721 6;1440..
2 |T;44.364445:/67;3 870435609;31T;560357.9;4912720.7;1441.2;;
o |T:44.364425¢31;3 870372310;31T;569352.9,4912718 5;1442_1;;

10 |44 3644147(33.3 870338587,31T,5692350.2:4912717.2,1442 6
11 |44 3644001413 870321745,31 7569248 8,4912716.6; 1442 .
12 |T:44.3644065/22:3 870313318;31T:569348.2:4912716.2;1443.0;; Apercu des données sélectionnées :
13 |44 364400¢l01:3 870300633,31 7569247 2:4912715.6,1443.1;;
14 |44 364395152,3 870275471,31T.669345 2,4912715,1443 5,

15 |44 3643924(75.3 870262924,31T569344 2:4912714.7,1443.6;;
16 |44 364386¢)14.3 870241931,31T,569242 5:4912714,1443.7;
17 |44 3643843(73.3 870221059,31 7569240 8:4912713.7,1443.9;;
15 |44 364378¢|14.3 870195943,31 7569338 9,4912713.1,1444.0;;
12 |44 364370el40:3 870166590,31T:569336 5,4912712.1; 1444 .
20 |44 3643652/84.3 870133234,31T,569333.9,4912711 5, 1444 .
21 |44 3643601(32;3 870095781,31T,569330.9,4912710.9;1444.7;

;latitude;longitude;utm zone;utm_easting;utm northing;altit]A

36428938273 .070645091;31T; 569374 .87 4912725 _7;1437_1;Sans

.3€4272991;3.870588€€9; 31T; 569370, 4912723.9;1438.4

36446887773 8705332007 31T; 569365 . €; 4912723 _4;1439

36446099273 .870495121;31T; 565362 .5; 4512722 §;1440_1;; v
>

Annuler < Précédent | | Suivant > Terminer

Figure 12 : Excel data

e Click on “Next” and select “Semi-colon” as delimiter, click on “Next”

e Remove the first 4 columns (from “type” to “utm_zone”), keep only columns
“utm_easting”, “utm_northing” and “altitude”

F6 - Fx

A B C D

1 |utm_easting utm_northin altitude (m)
2 | 569374.8  4912725.7 1437.1
3 | 569370  4912723.9 1438.4
4 | 569365.6  4912723.4 1439.5
3 | 569362.9 4912722.5 1440.1
& | 569359.9  4912721.6 1440.7
7 569359.6  4912721.6 1440.8
g | 569357.9  4912720.7 1441.2
9 569352.9 4912718.5 14421
10| 569350.2  4912717.2 1442.6
11| 569348.8 4912716.6 14428
12 | 569348.2  4912716.2 1443
13 | 569347.2  4912715.6 1443.1
14 | 569345.2 4912715 1443.5
15| 569344.2 4912714.7 1443.6
16 | 369342.5 4912714 1443.7

Figure 13 : Data

e Save as .CSV and close excel
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e InPVsyst 3D scene, from the menu “File>Import>Import ground data (CSV)”,
select and import your file

e - )
Shading scene construction

FE

Sy 0

“%x @ WELEE

Help

yo@oan L e

Point of view

Zeni

Import a 30 scene (305, DAE, PVC)
Import a Helios3D file (H2P)
Import ground data (C5V)

Import a ground image

Create  Select Edit View Tools
New scene Ctri+N
Read scene Ctrl+0
Read building
Read ohjects
Import
Export scene (.SHD) Ctrl+5
Export selected objects ((SHO)
Save scene view
Print Ctrl+P
Cancel Ctrl+Q
Close scene Ctrl+W

"
",
o

Figure 14 : PVsyst - Import ground data

e Yourtopography should be correctly imported. Please note that if you are in the
Northern hemisphere you might need to rotate the ground object by 180° around the
scene origin in order for it to be properly placed

L Shading scene construction

File Create Select Edit VYiew Tools Help

e [h@-Q-

History

Selection

{ Zenith

Naflaas .t [eqaq

Point of view

Zoom

East

.J.
Meas

@ O

Render

Figure 15 : PVsyst ground
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3 Converting an Autocad .DWG to .DAE from sketchup

e Open Sketchup Pro

e Click on “File>Import” and select an Autocad .DWG file
e Click on “File>Export>3D model”

e Select “Collada (*.DAE)” and save your file.

e InPVsyst 3D scene, from the menu “File>Import>Import a 3D scene (3DS, DAE,PVC)”,
select and import your file

4 Importing a ground from sketchup

e Open Sketch Pro

e Clickthe "Add Location tool" - on the Location toolbar or select
"File>Geolocation>Add - Location".
e Inthe “Add Location” window that appears, type an address or

intersection where your desired terrain is located.
e Clickthe "Search" button, and an aerial view of your location appears in the window.
e Click “Select Region” in the upper right.

e Dragthe corners of the selection box to refine the location.

e Clickthe “Grab” button in the upperright, and your location’s terrain is imported into your
model as a layer.

® Ajouter un emplacement

Type de carte

.
1
[CRTOT  Plan des rues

Importation de la X
région

Résolution @ Haure

Fournisseur dimages @

@ Ciiquez ou faites glisser pour sélectionner des objets. Maj = Ajouter/Soustraire. Ctrl = Ajouter. Maj + Ctrl = Soustraire.

Figure 16 : Sketchup Import ground
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e Inthe layers list, make “Snapshot” layer invisible and “Terrain” layer visible :

L S L x

> Styles x

v Balises x|

® 3 IRechercher | o ®
Nom N

&  Sans balise

O

Figure 17 : Location terrain

e Rightclick on the ground image and select “Unlock” then “Explode”

Figure 18 : Ground under Sketchup
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e From menu “File>Export>3D model”, save the terrain as “.DAE” file

e InPVsyst 3D scene, from the menu “File>Import>Import a 3D scene (3DS,
DAE,PVC)”, select and import your file

e Clickon “OK” in the import dialog: your 3D object is imported in the 3D scene

e Right-click on it and select “Transform to a ground object”

* Shading scene construction

File Create Select Edit View Tools Help

e [Ma-a- [yaleatt |ee@q (90 [~ 4 |vea |/
History Selection Point of view . Zoom . Render Measure Modify 1
I&I"ff)‘r'i'.h_~ Zenith East

Ctrl+M
Ctrl+B
Ctrl+R

Maove

Rotate

Transform to a ground object

Copy
Delete object

71 Look at selected object Ctrl+F

Specify observer position

.West

Figure 19 : PVsyst - Transform to a ground object
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